Metagames  


Précédent   Metagames > Discussions Générales > Forum électronique

Forum électronique Venez parler de résistances, de potards, de transistors et de LED...

Réponse
 
Outils de la discussion Modes d'affichage
Vieux 14/12/2021, 19h52   #1 (permalink)
Profil
···· ·- -- ·- - ---
Ancienneté  49%
Ancienneté 49%
 
Avatar de Hamato
 
Date d'inscription: décembre 2008
Genre : Homme
Pays :
Messages: 10 771
Téléchargements: 14
Uploads: 3
Merci: 368
Remercié 853 fois dans 540 Posts
Par défaut Capteur CCS811 sur Raspberry b+

Hello,

J'ai un capteur CCS811 branché sur un Raspberry B+,
Les data eco2 et tvoc arrivent bien et d'un coup au bout de quelques minutes/heures j'ai un IOError qui apparaît. Installé vers 13H. ça m'est arrivé 2 fois en 5H, sachant que j'ai coupé pour mise à jour de fonctionnalités de mon script. Donc en théorie ça coupe avant 2H de fonctionnement.
Je relance mon script python sans rien touché et ça repart direct.


Vu que ça ne bouge pas, j'élimine sans trop me tromper un faux contact.
Branché et configuré comme sur la doc.
Raspian upgradé en Buster (v10), lancé avec python 3.7, avec/sans sudo.Pour le code, je n'ai pas pris en compte la température. Et j'ai mis une tempo de 5 sec après la mesure.


Est-ce que ce modèle de Rasp est sous-dimensionné (mais ça semble être un B+ aussi sur la doc) et fini par saturer ou j'ai zappé un truc ?
Après les dépôt adafruit sont pas les plus simples : entre le github déprécié et pip, j'ai peut être pas les bonnes libs au final.

J'ai relancé vers 18H en partant du bureau, je verrai demain matin en arrivant à quelle heure il aura planté :p

Donc avant de contacter le support, un petit message sur le forum Si vous avez des pistes à surveiller je suis preneur.

Doc CCS811 : https://www.gotronic.fr/pj2-sen-ccs8...05-19-2004.pdf
__________________
Discord MetaGames :

https://discord.gg/88WNwhEUDG
Hamato est déconnecté   Réponse avec citation
Vieux 06/01/2022, 19h02   #2 (permalink)
Profil
···· ·- -- ·- - ---
Ancienneté  49%
Ancienneté 49%
 
Avatar de Hamato
 
Date d'inscription: décembre 2008
Genre : Homme
Pays :
Messages: 10 771
Téléchargements: 14
Uploads: 3
Merci: 368
Remercié 853 fois dans 540 Posts
Par défaut

Je suis parti en congé en oubliant de récupérer le matos et là c'est branle bas de combat au boulot, mais je rejette un oeil dessus ASAP xD
__________________
Discord MetaGames :

https://discord.gg/88WNwhEUDG
Hamato est déconnecté   Réponse avec citation
Réponse
Précédent   Metagames > Discussions Générales > Forum électronique

Tags
capteurs, diy, raspberry

Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non
Trackbacks are non
Pingbacks are non
Refbacks are non


Discussions similaires
Discussion Auteur Forum Réponses Dernier message
Le Ez Flash 4 pour les nuls ccosmos EZ-Flash 169 23/05/2022 12h56
N64,Modifier les graphiques de the legend of zelda ocarina of time 1.0(u) mojo1119 Oldies, Rétrogaming 60 09/02/2021 05h08
[TUTO] L'univers multijoueur sur Playstation 2 RésistantFTW Les Tutoriels PlayStation 2 40 03/01/2021 17h38
Discussion général et Tuto sur "Fortuna Project" (Alternative à FMCB) KAAN3KII Playstation 2 6 01/08/2020 12h22
Injecter des backups sur PS3 en OFW 4.82 piopio Playstation 3 2 20/04/2019 16h44


Fuseau horaire GMT +1. Il est actuellement 13h09.


© 2003-2018 MetaGames. Tous droits réservés.