Metagames  

Vieux 03/11/2013, 19h40   #61 (permalink)
Profil
French frog
Ancienneté  21%
Ancienneté 21%
 
Avatar de ShaoliAss
 
Date d'inscription: juin 2012
Localisation: Bordeaux
Genre : Homme
Pays :
Messages: 1 468
Téléchargements: 8
Uploads: 0
Merci: 122
Remercié 522 fois dans 355 Posts
Par défaut

Citation:
Pour booter le lanceur depuis l'USB avec FHDB, il faut que le lanceur soit renommé en NOM_DE_PARTITION.ELF. J'ai testé ça hier, ça a marché.
Ouaip, pour booter le lanceur depuis le HDD avec FHDB, il faut impérativement qu'il soit placé dans la bonne partition de jeu.
Je n'ai pas ce résultat si je renomme mes launchers en test.ELF (toujours placés sur l'USB)
- la version normale me renvoie une erreur de préfixe (tes ---> pour ma partition nommée PP.test je suppose)
- la version no_debug me renvoie tjrs sur le TESTMODE
ShaoliAss est déconnecté   Réponse avec citation
Vieux 03/11/2013, 21h01   #62 (permalink)
Profil
Membre
Ancienneté  16%
Ancienneté 16%
 
Avatar de krHACKen
 
Date d'inscription: juillet 2013
Pays :
Messages: 764
Téléchargements: 0
Uploads: 0
Merci: 215
Remercié 698 fois dans 441 Posts
Par défaut

Enfin, j'voulais dire NOM_DE_PARTITION.ELF mais avec un préfixe, comme d'hab.
Par exemple, ton test.ELF devrait être PP.test.ELF ou __.test.ELF
Aussi, je crois que l'extension .elf peut fonctionner en minuscule, ainsi que ses variantes Elf, eLf, elF...

EDIT : Pardon, je viens de relire ton post d'avant et j'ai vu que tu as correctement nommé tes fichiers en PP.test.elf.
Très bizarre. À en juger par le message d'erreur, le truc qui transforme le nom de ton ELF en nom de partition de trouve pas le préfixe PP. et commence après, à "tes". J'ai pas eu ce problème.

Dernière modification par krHACKen ; 03/11/2013 à 21h05.
krHACKen est déconnecté   Réponse avec citation
Vieux 03/11/2013, 21h06   #63 (permalink)
Profil
French frog
Ancienneté  21%
Ancienneté 21%
 
Avatar de ShaoliAss
 
Date d'inscription: juin 2012
Localisation: Bordeaux
Genre : Homme
Pays :
Messages: 1 468
Téléchargements: 8
Uploads: 0
Merci: 122
Remercié 522 fois dans 355 Posts
Par défaut

Ok, j'avais pas pigé. Mais dans ce cas là (PP.test.ELF) je n'arrive pas à faire marcher POPS avec le launcher sur l'USB. (enfin te prends pas le tête non plus...)

____

Edit : le launcher normal (PP.test.ELF), lancé depuis la CM1 me renvoie l'erreur 108. (avec uLE) Correction : POPS se lance.


Re-edit : t'avais bien compris, j'ai fait un deuxième essai en les nommant "test.ELF".

Dernière modification par ShaoliAss ; 03/11/2013 à 21h23.
ShaoliAss est déconnecté   Réponse avec citation
Vieux 03/11/2013, 21h36   #64 (permalink)
Profil
Membre
Ancienneté  16%
Ancienneté 16%
 
Avatar de krHACKen
 
Date d'inscription: juillet 2013
Pays :
Messages: 764
Téléchargements: 0
Uploads: 0
Merci: 215
Remercié 698 fois dans 441 Posts
Par défaut

Avec FHDB 1.93, sans HDDOSD :
"mass:/PP.test.elf" a fonctionné.
"mass:/2013-11-02_Launchers_for_POPStarter_Rev.12/Normal/PP.test.elf" m'a foutu l'erreur illegal path.
"mc?:/PP.test.ELF" a fonctionné.
"mc?:/TEST.test-Test_TeSt/PP.test.ELF" a fonctionné.

Ou bien le lanceur pète un plomb pour cause de chemin d'accès trop long, ou bien FHDB envoie un argument tronqué. Je vais voir ça de plus près.

EDIT :
Ouaip, c'est un bug dans FHDB 1.93. L'argument est tronqué (nom du ELF remplacé par une arobase), ou bien peut être est-ce volontairement codé de la sorte...

Dernière modification par krHACKen ; 03/11/2013 à 21h50.
krHACKen est déconnecté   Réponse avec citation
Vieux 03/11/2013, 21h52   #65 (permalink)
Profil
French frog
Ancienneté  21%
Ancienneté 21%
 
Avatar de ShaoliAss
 
Date d'inscription: juin 2012
Localisation: Bordeaux
Genre : Homme
Pays :
Messages: 1 468
Téléchargements: 8
Uploads: 0
Merci: 122
Remercié 522 fois dans 355 Posts
Par défaut

Citation:
Envoyé par krHACKen Voir le message
"mass:/2013-11-02_Launchers_for_POPStarter_Rev.12/Normal/PP.test.elf" m'a foutu l'erreur illegal path.
(...)

Ou bien le lanceur pète un plomb pour cause de chemin d'accès trop long, ou bien FHDB envoie un argument tronqué. Je vais voir ça de plus près.
Bien vu. Ca marche de mon côté aussi si le launcher est à la racine de l'USB.


Citation:
EDIT :
Ouaip, c'est un bug dans FHDB 1.93. L'argument est tronqué (nom du ELF remplacé par une arobase), ou bien peut être est-ce volontairement codé de la sorte...
En même temps, y a que moi pour faire des chemins à 50 caractères. Mystère résolu - et désolé pour cette boulette.

Dernière modification par ShaoliAss ; 03/11/2013 à 21h57.
ShaoliAss est déconnecté   Réponse avec citation
Vieux 03/11/2013, 22h07   #66 (permalink)
Profil
Membre
Ancienneté  16%
Ancienneté 16%
 
Avatar de krHACKen
 
Date d'inscription: juillet 2013
Pays :
Messages: 764
Téléchargements: 0
Uploads: 0
Merci: 215
Remercié 698 fois dans 441 Posts
Par défaut

Citation:
Envoyé par ShaoliAss Voir le message
En même temps, y a que moi pour faire des chemins à 50 caractères. Mystère résolu - et désolé pour cette boulette.
Aucun problème. Ça m'a permis de passer en revue quelques trucs et de voir si tout fonctionne bien.

Un peu hors sujet, POPStarter a une limite du nombre de caractères pour le nom de la partition. Le truc qui est sensé afficher une erreur quand cette limite est dépassée ne fonctionne pas dans la r12. Ça a été corrigé dans ma build perso.
Je ne compte pas faire une "correction rapide" pour la r12, parce que la manière de paramétrer l’environnement à complétement changé dans ma build perso. Elle va chercher les IMAGE0.VCD à l'ancienne dans des partitions PP. et __., mais traite aussi les VCDs nommés en nom_du_jeu.VCD et placés dans une partition unique. L'environnement est aussi "enregistré" dans un autre emplacement dédié, dans le cœur de POPS, justement pour éviter les écrasements et les bugs...
krHACKen est déconnecté   Réponse avec citation
Vieux 03/11/2013, 22h13   #67 (permalink)
Profil
French frog
Ancienneté  21%
Ancienneté 21%
 
Avatar de ShaoliAss
 
Date d'inscription: juin 2012
Localisation: Bordeaux
Genre : Homme
Pays :
Messages: 1 468
Téléchargements: 8
Uploads: 0
Merci: 122
Remercié 522 fois dans 355 Posts
Par défaut

Citation:
Envoyé par krHACKen Voir le message
Je ne compte pas faire une "correction rapide" pour la r12, parce que la manière de paramétrer l’environnement à complétement changé dans ma build perso. Elle va chercher les IMAGE0.VCD à l'ancienne dans des partitions PP. et __., mais traite aussi les VCDs nommés en nom_du_jeu.VCD et placés dans une partition unique. L'environnement est aussi "enregistré" dans un autre emplacement dédié, dans le cœur de POPS, justement pour éviter les écrasements et les bugs...
Avec ça, tu vas faire plaisir aux espagnols je crois. Ils font une grosse partition unique, avec tous leurs jeux et renomment le jeu qu'ils veulent lancer en IMAGE0.VCD
Sinon quel est l'avantage? préparer les choses pour un GUI éventuellement?
ShaoliAss est déconnecté   Réponse avec citation
Vieux 03/11/2013, 22h42   #68 (permalink)
Profil
Membre
Ancienneté  16%
Ancienneté 16%
 
Avatar de krHACKen
 
Date d'inscription: juillet 2013
Pays :
Messages: 764
Téléchargements: 0
Uploads: 0
Merci: 215
Remercié 698 fois dans 441 Posts
Par défaut

Citation:
Envoyé par ShaoliAss Voir le message
Avec ça, tu vas faire plaisir aux espagnols je crois. Ils font une grosse partition unique, avec tous leurs jeux et renomment le jeu qu'ils veulent lancer en IMAGE0.VCD
Sinon quel est l'avantage? préparer les choses pour un GUI éventuellement?
Je ne projette pas de coder un GUI. Ça serait pourtant plus simple à utiliser que de devoir lancer un maudit ELF pour chaque jeu, mais je laisse ce boulot à qui voudra bien le faire. Enfin du moins, tant que je n'ai pas fini d'étudier les possibilités de bidouillage du cœur de POPS, j'ai pas envie de faire un GUI.
Le but d'avoir une seule partition pour stocker les VCDs était surtout de gagner en place, d'éviter la fragmentation des segments des partitions mais surtout de simplifier les tests en tout genre...
Donc mon POPStarter cherche le VCD dans la partition __.POPS. Si il n'est pas trouvé, alors il cherche successivement dans __.POPS.0, __.POPS.1, __.POPS.2... jusqu'à __.POPS.9
krHACKen est déconnecté   Réponse avec citation
Vieux 04/11/2013, 08h24   #69 (permalink)
Profil
French frog
Ancienneté  21%
Ancienneté 21%
 
Avatar de ShaoliAss
 
Date d'inscription: juin 2012
Localisation: Bordeaux
Genre : Homme
Pays :
Messages: 1 468
Téléchargements: 8
Uploads: 0
Merci: 122
Remercié 522 fois dans 355 Posts
Par défaut

Ok, merci pour ta réponse.

Pense à mettre à jour le lien sur ASSEMbler avec les bons launchers, c'est toujours la première version là bas.
ShaoliAss est déconnecté   Réponse avec citation
Vieux 04/11/2013, 08h36   #70 (permalink)
Profil
Membre
Ancienneté  16%
Ancienneté 16%
 
Avatar de krHACKen
 
Date d'inscription: juillet 2013
Pays :
Messages: 764
Téléchargements: 0
Uploads: 0
Merci: 215
Remercié 698 fois dans 441 Posts
Par défaut

C'est fait, dans le 1er post.
Je n'ai pas fait d'annonce, parce que le changement ne concerne que le fonctionnement avec une version obsolète et "non-officielle" de FMCB, et je sens que je vais me faire tacler si je bump avec une si pauvre update.

J'viens de finir la conversion de ma codelist contenant les jeux Jap+US+UK+FR. Je vais vérifier aujourd'hui ou demain que tout s'affiche correctement dans le GUI de ps2rd puis me pencher sur le widescreen.
krHACKen est déconnecté   Réponse avec citation
Réponse
Précédent   Metagames > Univers Playstation > Playstation 2 > Les Tutoriels PlayStation 2

Tags
ps1 hdd emulateur ps2

Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non
Trackbacks are non
Pingbacks are non
Refbacks are non


Discussions similaires
Discussion Auteur Forum Réponses Dernier message
WAD mannageur 1.7, ca sert a quoi? il y a de tuto sur les emulateur ? evian145 Wii 1 13/03/2011 19h20
[TUTO] Emulateur Mame petitdav Les Tutoriels PSP 25 03/06/2010 17h58
emulateur snes + tuto snake1305 Playstation Portable 6 08/01/2006 17h20
Précision tuto "Emulateur Snes sur PS2" Invité Playstation 2 7 23/11/2004 20h24
tuto emulateur neogeo Invité Dreamcast 13 15/05/2004 21h53


Fuseau horaire GMT +1. Il est actuellement 17h54.


© 2003-2018 MetaGames. Tous droits réservés.